
  www.sojomedia.com | info@sojomedia.com | +44 (0)1573 420 367 

 

   Waukford, Kirk Yetholm, Kelso, TD5 8PG 
 

1

Flash MX Project 7 – Firework Display 
 

A multi-coloured firework explodes dramatically in the night sky 
Includes: Symbols, movie clip instances, masking, sound 
Extension: Button actions 

 
 

Process 
• Create a firework base on Scene 1 
• Create 2 movie clips – 

o ‘whoosh’ – the motion from the firework into the night sky 
plus sound 

o ‘scatter’ – the explosion of light (using masking) plus sound 
• Create a single ‘firework’ movie clip from ‘whoosh’ and ‘scatter’ 
• Create a ‘display’ clip using instances of ‘firework’ which start 

at different times, have different colours and are rotated 
differently 

• Place ‘display’ behind the firework base on Scene 1 and test 
movie 

 
Extension 

• Add an invisible button to activate the firework 
 
 
1. Getting ready and creating the firework base 
 
Open a new movie in Flash MX. 
 
Create a black background by going to Modify menu > Document… and changing 
the Background Colour. Save the project. 
 
Re-name Layer 1 as ‘firework base’ (double-click the layer name to change it) 
and press enter. 

 
Click the Rectangle tool and choose a bright colour. Set the Stroke tool 
to ‘No  colour’, so that there will be no border. Draw out a small 
rectangle at the bottom of the stage. 
 

 
2. Creating the ‘whoosh’ movie clip 
 
Go to the Insert menu > New Symbol… 
 
Name it whoosh and make sure it is a movie 
clip. Click OK. 
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You are now in the ‘whoosh’ editing timeline.  
Name Layer 1 ‘ball’. 
 
You are going to create a white fuzzy ball shape which will shoot up into the sky 
from the firework base. Insert menu > New Symbol… and name it ‘ball’, making it 
a graphic. To get an interesting effect, you are going to use the Colour Mixer 
panel at the top right of the screen.  
If the panel is not there, go to the Window menu and click ‘Color Mixer’. 
 

Make sure that the Stroke is set to ‘No colour’ 
and choose Radial from the drop-down list. 
 
If you cannot see the expanded version, as 
below, click the little arrow in the bottom 
right corner. 

Set the colour to black in the colour picker to 
the left of the drop-down list. (We want a 
black and white ball shape) 

 

 Try for a similar effect to that below: 

 

Now choose the Oval tool and drag out a small circle in the centre of the stage.  

Return to the whoosh movie clip by double clicking 
on it in the Library. Click on frame 1 of the ‘ball’ 
layer and drag in the ‘ball’ graphic symbol. 

Next you are going to add a sound file so that we 
can make the firework match the sound. You will 
find the files at: 

www.sojomedia.com/flashresources 
Click on the ‘whoosh’ link and save the file to your 
my Work folder. While you are at the site, save the 
‘scatter’ sound file too. 

Go to the File menu > Import to Library. Navigate to your sound files. Select both 
whoosh.wav and scatter.wav by holding down the Ctrl key. Click Open. 

Choose an overall 
colour here  

This shows the 
effect you have 
achieved 

Click a pointer to change its 
colour from the palette below 

Click on or below the gradient
bar to add a pointer. 
 
Drag a pointer down and off 
the gradient bar to remove it. 

The gradient bar 

The brightness control 
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The sound files are now in the Library. Go to Window menu > Library. You should 
see them there, along with your ‘whoosh’ movie clip.  

Add a new layer using the Insert Layer tool (+ sign) and name it ‘sound’. 

Select the ‘sound’ layer and drag the whoosh.wav from the Library onto the stage 
(it does not matter where). Now, on the ‘sound’ timeline, insert a keyframe (right 
click on the frame) at frame 20. You will see the sound file in the timeline. Notice 

that the sound has finished 
before frame 20 is reached, 
which is what we want. 

 

Next, insert a keyframe at frame 20 on the ball layer and move the ball vertically 
up the stage, using the Arrow tool. Finally Create Motion Tween (right click on 
frame 1). 

Press Enter to test the ‘whoosh’ movie clip. You can 
experiment with the Easing effect to make the ball 
move faster at the beginning than at the end. Click 
on frame 1 and find the Ease slider in the Properties 
panel. You want to Ease Out rather than In (which would make it slower at the 
beginning). 

At the moment the movie clip is looping so you need to 
put a stop on the final  frame. Right click in frame 20 (ball 
layer) and choose Actions. Open Movie Control then 
double click ‘stop’. 

Save. 

 

3. Creating the ‘scatter’ movie clip 

Go to the Insert menu > New Symbol… Name it scatter and make sure it is a 
movie clip. Click OK. You are now in the ‘scatter’ movie clip timeline. 

This effect is going to involve a mask layer on top of a moving background layer. 

Rename Layer 1 as ‘scatter’. Move to the Color Mixer 
and remove all but 2 of the pointers. Click on each in 
turn and set their colour to white with the colour 
picker. You should have a completely white gradient 
bar with 2 pointers.  

Set the first pointer to Alpha 0%. (Click on it and use 
the slider) 

Set the second pointer to white. 

Add a third pointer near the end and set it to a bright 
orange colour. 

To save this combination, you can click at the top 
right and choose ‘Add Swatch’. The sample will be added to the Color Swatches 
panel.
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Set the Stroke tool to ‘No Colour’ or black. Click the first frame of the ‘scatter’ 
layer and draw a small circle in the centre of the stage. It should appear as  
concentric circles, with black in the middle.  

Select the circle by clicking on frame 1. Convert the circle to a symbol – Graphic 
– and call it ‘scatterbg’. This circle will be the background of the mask. 

Insert a keyframe in frame 20 and use the scale tool to enlarge the circle to as 
big as it can go, so that part of it is off the screen. Finally click on the first frame 
and Create Motion Tween. Press Enter to view the effect. Gauge the size of the 
blank centre of scatterbg at frame 20 – your mask should aim to fit roughly inside 
that space. 

Add a new layer and name it ‘mask’. Click in 
frame 1, select the brush tool, any colour 
and the smallest brush size. Draw out 
curved lines from the small circle, like this, 
the smoother the better:  

Now right click on the mask layer name and choose 
Mask. 

The scatterbg layer is now 
hidden behind the mask. 
Press Enter to see the 
effect. 

Note that both layers are now locked. You will have to unlock the layer if you 
want to change anything. 

Next, add a new sound layer and drag in the ‘scatter.wav’ sound from the library 
as you did before. This sound is a loud bang so it should be placed on frame 1 
and then a further keyframe inserted at frame 20. 

 

Finally add a stop to frame 20 as you did before for the whoosh movie clip. Save. 

 

4 Joining the 2 movie clips together to form the ‘firework’ movie clip 

Go to the Insert menu > New Symbol… Name it firework and make sure it is a 
movie clip. Click OK. You are now in the ‘firework’ movie clip timeline. 
 

 
 
Create layers as above. Drag movie clip ‘whoosh’ from the Library into frame 1 of 
the whoosh layer. Drag movie clip ‘scatter’ from the Library into frame 20 of the 
scatter layer. Each clip lasts 20 frames, so insert a frame at 20 on the whoosh 
layer and at 40 on the scatter layer. Don’t forget to add a stop action to the final 
frame of the clip. 
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You will have to place this movie clip on to a Scene in order to test it. 
 
Return to Scene 1. Add a new layer, name it 
firework and drag the firework movie clip onto the 
stage near the bottom. You are just testing, so it 

does not matter where. Then press Ctrl + Enter to set off the firework. Success? 
You should see the whoosh, followed by the scatter and then it should stop. If 
you are getting extra explosions, you have probably forgotten to put a stop on 
somewhere.  
 
Remember that you can alter the original symbols if necessary. For example, if 
the ball is too large, open the ball graphic symbol by double clicking and scale it 
down. 
 
You have now created a firework, but we can make it a lot more exciting fairly 
easily. 
 
5. Creating a more spectacular firework display using the ‘firework’ 
movie clip 
 
Go to the Insert menu > New Symbol… Name it display and make sure it is a 
movie clip. Click OK. You are now in the ‘display’ movie clip timeline. 
 
Create 5 layers, named white, red, blue, yellow, green. 
 
Click in frame 1 of the ‘white’ layer. Drag in a firework movie clip and drop it onto 
the stage. Insert a frame at frame 40 (the firework movie clip is 40 frames long) 

 
Click in frame 10 of the red layer. Drag in a firework 
clip as before and place it on top of the previous 
one. Look in the Properties panel and use the drop-
down Color list to select Tint. By choosing a bright 
red, the firework will change from white to red! Now 
insert a frame at 50 (frame 10 plus the 40 frames 
required for the movie clip). 
 

Do exactly the same for the other layers, changing the colour each time. You may 
wish to vary the timeline for a more realistic effect, eg moving the blue firework 5 
frames along the timeline instead of 10 as before. 
 

 
 
Don’t forget to put a stop onto the final frame of the movie clip.  
Test it out by returning to Scene 1. Delete the firework movie clip from the stage 
and drag in the ‘display’ clip. Ctrl + Enter to view. 
 
You can improve the effect by making the firworks shoot out from slightly 
different angles. Return to the ‘display’ movie clip editing window. Click on the 
first frame of the green firework so that the green ball is selected. Click on the 
Scale tool. Rotate the ball slightly to left or right. Note: If the registration point is 
not in the centre of the ball and it is not rotating properly, simply pick it up and 
drag it to the centre of the ball. Ctrl + Enter to test out the effect. 
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Continue to alter the display clip and test until you are happy. 
 
In order to make the firework will appear from 
behind the rectangle on the screen, you will 
have to move the ‘firework’ layer below the 
‘firework base’ one. 
 
 
6 Adding an invisible button to activate the firework 
 

Add a new layer to Scene 1 and name it ‘button’. 
Drag out a rectangle (with no stroke) which 
covers the firework base rectangle. The colour 
does not matter as it will be invisible. Select the 
rectangle and Convert to Symbol, call it button 
and make sure that it is a Button.  
 
Look at the Properties window and choose Alpha 
from the Color drop-down list. Slide the Alpha 

scale to 0%. The button should now be invisible. 
 
You need to move the display clip to frame 2, as frame 1 is just for the button 
and the firework base. Either double-click to select it or hold down shift and then 
click. Drag it to frame 2. Insert a frame on frame 2 of the ‘firework base’ layer so 
that the firework base remains in the animation. 
 
Click on the button layer and then click the button itself 
on the stage. Use the Actions window to set the button to 
play frame 2 on release. Look at Project 5 for more detail 
on how to do this. 
 
Place a stop action on frame 1 of the firework base layer 
so that the movie does not start until the button is pressed. 
 
Place a stop action on frame 2 of the firework layer, otherwise the movie will not 
work. 
 
Test the movie out with Ctrl + Enter. You will see that you cannot click the base 
to re-activate the firework for a second time. To solve this you will need to return 
to the ‘display’ movie clip. Instead of a simple stop action on the last frame, we 
need to type some code to tell the clip to return to the ‘root’ (Scene 1 in this 
case) and play frame 1 of that root. 
 
Open the display movie clip. Select the final frame. 
Go into Expert Mode (top right of Actions panel). 
 
Delete the stop action and type in: 

 
 
Check the movie again with Ctrl + Enter. 
 
Why not try some other fireworks using the same methods? Different fireworks 
could have different effects. Perhaps a Guide layer could be used eg to make a 
spiralling spark…? The sky’s the limit! 


