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Macromedia Flash MX 
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Flash animation 

Note: This tutorial is for teachers. It is 
not suitable for use with primary pupils. 
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Macromedia Flash MX – Key Concepts Tutorial 
 

Jo King 
 
 
 
Overview 
 
Flash is a powerful piece of software, with applications ranging from a vector-
based drawing package at one end to a highly complex ActionScript programming 
language at the other.  
 
Somewhere between these two extremes lie the ‘Key Concepts’ that specifically 
identify Flash as an animation tool. This tutorial will explore these basic animation 
Key Concepts through a series of short projects. 
 
Please note that this tutorial uses Macromedia Flash MX. Anyone using MX 2004 
may notice slight differences in menus and tools. 
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Flash Animation – the 6 Key Concepts 
 

 
Key Concept 1: Layers  
 
Layers work like sheets of clear plastic on top of each other. If you look at all the 
layers together, you can see the whole animation, but each separate layer only 
contains a small part of the whole animation. In effect, you build up your 
animation from lots of small parts, each part on a different layer. 
 
Key Concept 2: Timeline 
 
The timeline is divided up into numbered blank frames. You control the order that 
things happen in your animation by placing events in different frames along the 
timeline. The default setting for Flash is 12 frames per second, so every 12 
frames represents one second of animation 
  
Key Concept 3: Keyframes 
 
You control changes in your animation by positioning keyframes along the 
timeline. A keyframe position indicates which layer is affected and where on the 
timeline that change happens. 
 
Key Concept 4: Symbols and Instances  
 
Symbols are part of the reason that Flash produces such small files. When you 
create a symbol, Flash stores it in its library. Next time you use your symbol in 
the animation, Flash refers to its library copy. So a symbol can be used hundreds 
of times in an animation or just once – the file size is the same.  
 
There are 3 kinds of symbols: Graphic, Movie Clip and Button 
 
By editing a symbol, you change all the examples of it in your animation. You can 
also copy a symbol and change its size, colour and transparency without affecting 
the original symbol. This copy is called an ‘instance’. 
 
Key Concept 5: Tweening 
 
In traditional animation, if you were moving an object across the stage, you 
would have to set its new position in every frame in the timeline. With tweening, 
all you have to do is set the first position and the last position. Then you ask 
Flash to add tweening to fill in the animation between the 2 keyframes. There are 
two kinds of tweening: 

• Motion tweening is used when symbols are changed. It covers position 
change, colour change, alpha (transparency) change, rotation and 
scaling changes. 

• Shape tweening is used when one shape is deformed into another. 
Neither of these shapes can be symbols. 

 
Key Concept 6: Buttons and ActionScript 
 
If you want users to interact with your animation, you need to use buttons. Once 
you have created a button symbol, you can assign actions to it using ActionScript, 
so that something happens when the user clicks interacts with that button. 
Back to contents
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Project 1 – Face 
 

Eyes, nose and mouth appear one after the other to create a finished face 
New Key Concepts: Layers, Timeline, Keyframes 

 
1. Organising Layers by Naming 
 
Get into the good habit of naming 
each layer as you go along. 
 
Double click to re-name the existing 
layer from ‘Layer’ to ‘face’. 
 
 
Use the ‘Insert Layer’ tool to add 
layers and re-name each one, until 
you have 4 layers in place – eyes, 
nose, mouth and face. 
 
 
2. Drawing the face background 
 
Click on the first keyframe on the face layer.  
 
Using the Oval tool, a suitable fill colour and the 
Stroke set to ‘No Colour’ (ie no border), draw a 
large face on the stage. 
 
At the moment the face is only on frame 1. As 
soon as frame 2 is played, it will disappear (click 
on frame 2 to check). You need to set the face 
background to stay there for the whole animation. Move along the timeline to 
frame 60, where the animation is going to finish (you can easily alter this later 
on). Make sure you are on the face layer, right click in frame 60 and Insert 
Frame.  
 

You do not need to insert a keyframe – 
keyframes are when something is changing and 
the face is not going to change. 
 
You should see the frames on the face layer 
change to a grey bar. Now when you click 
anywhere on the grey bar, you will see that the 
face stays on the stage. 
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3. Adding the other face parts to come in to the animation one by one 
 
Right click on frame 10 of the mouth layer. This time Insert Keyframe (because 
something is changing at that frame). Draw a mouth in frame 10.  
Note that the colour of the brush is chosen from the fill colour tool.  
 
You will need to insert a frame at 60 again, so that the mouth stays on the stage 
until the end of the animation.  
 
Insert a keyframe at 20 for the nose layer and one at 30 for the eyes layer. Do 
not make pupils or irises for your eyes. These will be added and animated in 
Project 2. Each time insert a frame at 60 as you did before. 
 
If you click on frame 60, you should have something like this: 

 
Double check that each 
part of the face is on the 
correct layer. Do this by 
clicking on the Hide Layer 
tool and checking that the 
correct part disappears: 
 

 
 
Clicking again on that tool 
will make the part 
reappear. 
 

 
4. Testing the animation 
 
Drag the playhead back to frame 1 and press Enter. You 
can also test the looping effect of your animation by going 
to the Control menu >Test Movie (or press Ctrl + Enter). 
Close down the Test Movie window to return to the Flash 
stage. Now save the project. 
 
 
5. Extension 
 
Drag the face layer above the mouth layer. What happens if you test the movie 
now? Can you see why the order of the layers is very important? 
 
Can you alter the keyframes so that the eyes appear first, followed by the nose 
and finally the mouth? 
Hint: Move a keyframe by shift-clicking to select it, and then dragging it into its 
new position. 
 
Back to contents 
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Project 2 – Eyes (Part 1) 
 

Animated eyes swivel from side to side 
New Key Concepts: Graphic Symbol, Motion Tween 

 
 
1. Drawing the moving part of the left eye 
 
You need to create another layer for the moving part of the eye. Insert a layer 
and make sure it is above the eyes layer. Call this layer ‘left eye’. The first frames 
in this new layer may well be empty and white – this does not matter.  

 
 
Right-click in the keyframe above the ‘eyes’ layer keyframe and Insert Keyframe 
there.  
 

Now use the Oval tool, select No Colour from the Stroke tool 
and black from the Fill palette to drag out a small black circle 
inside the left eye. You can select the circle with the arrow 
tool to position it accurately.  

 
 
2. Converting the circle to a symbol 
  
In order to animate this circle, and to re-use it for 
the right eye, you need to convert it to a symbol. 
 
First lock the other layers so that you don’t change 
them by mistake.  
 
Then use the arrow tool to select the black circle you drew on the ‘left eye’ layer. 
You will see it highlighted with small dots. Go to the Insert menu > Convert to 
Symbol. Choose Graphic and give it the name ‘circle’.  

 
Note: A Graphic symbol is one whose content remains 
static. You should choose Graphic if you just want to use a 
graphical object over and over again. 
 
You can see where Flash has stored this symbol by going 
to Window menu > Library.   
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3. Animating the circle 
 
Insert a keyframe on the 
‘left eye’ timeline, about 10 
frames further on than the 
first keyframe.  

 
Then use the arrow tool to select the black circle and move it to one 
side of the eye. Continue to insert keyframes and move the circle 
from side to side. Stop when you get to frame 60. 
 

 
Test the movie as before – you will see that the circle jumps from side to side. 
 
4. Adding motion tween 
 
You can make the circle move smoothly from side to side of the eye using motion 
tween. Click on the first keyframe of the animated sequence. Look at the 
Properties panel at the bottom of the window and select Motion from the pull-
down Tween options. You will 
notice that an arrow has 
appeared between that 
keyframe and the next. The 
frames also turn mauve, 
indicating motion tween.  
Note: You can also right-click 
anywhere between the 2 
keyframes and select ‘Create Motion Tween’ 
 
Continue to add motion tween until your timeline looks like this: 
 

  
 
Now test the movie again and see the difference. 
 
5. Animating the right eye 
 
First, insert a new layer and name it ‘right eye’. Insert a 
keyframe above the first keyframe in the ‘left eye’ layer. 
 
You are going to re-use the Graphic symbol you have 
already made. Simply drag the symbol from the Library 
window onto the stage, then use the arrow tool to 
position the circle inside the right eye.  
 
Animate in the same way. Now save the project. 
 
6. Extension 
 
Can you change the colour of the eyes from black to 
red? 
Hint: Try double-clicking on one of the black circle 
symbols. To return to the normal view, click Scene 1, 
underneath the Layers.  
Back to contents
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Project 3 – Eyes (Part 2) 
 

Achieve the same effect in a much cleverer way 
New Key Concept: Motion Clip Symbol 

 
 
1. Removing frames 
 
Note: This project uses the Eyes (Part 1) file, so open this first. 
 
You are going to return the animation to the state it was before you animated the 
circle symbol. Highlight all the frames of  the ‘right eye’ layer, by dragging across 
them, then right-click and select Remove Frames. Do the same for the ‘left eye’ 
layer. 

  
 
2. Inserting a new Movie Clip symbol 
 
Instead of using the ‘circle’ Graphic 
symbol and animating it yourself, you 
are going to create a Movie Clip 
symbol which will animate the circle 
for you.  
 
Go to the Insert menu > New Symbol. 
This time, select Movie Clip and call it 
‘moving eyes’  
 
Your scene will disappear and you will see the timeline of the Movie Clip ‘moving 
eyes’. This is where you will create the ‘moving eyes’ animation. Click on the first 
keyframe and then drag the ‘circle’ Graphic symbol from the library onto the 
stage. Notice that the ‘moving eyes’ Movie Clip symbol is also now in the library. 
 
Insert a keyframe into frame 10 and move the circle slightly to the right. Then 
insert a keyframe in frame 20 and move it back again. 
 

Note: You can line up objects exactly by going to View 
menu > Rulers. Click on either the horizontal or 
vertical rulers and drag a guide line onto the stage. 
Use 2 guides to mark the position of the first circle.  
 
Holding down shift and using the arrow keys will move an object 
quickly in a straight line.  

 
Create motion tween between the keyframes and then test the Movie Clip.  
 

Return to Scene 1.   
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3. Placing the Movie Clip in the animation 
 
Now insert a keyframe on the ‘left eye’ layer, as before.  
 
This time drag the Movie Clip ‘moving eyes’ from the 
library and position it inside the eye.   
 
Movie Clips loop automatically, so all you need to do 
now is insert a keyframe in frame 60 and test the movie 
(Ctrl + Enter only, not the playhead). If you need to 
adjust the Movie Clip to make it fit inside the eye, 
double-click on it to edit it.  
 
You can complete the ‘right eye’ layer in exactly the same way. Now save the 
project. 
 
4. Extension 
 
Can you use the same Movie Clip to make the right eye move inwards at the 
same time as the left eye, to give a cross-eyed effect?  
 

  
 

Can you think of how you would animate the mouth in a similar 
way? 
Hint: It must be converted to a graphic symbol first.  
You could transform the mouth by changing size and rotation. Use 
the Free transform Tool or go to Modify menu > Transform > Scale 
and Rotate.  
Back to contents
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Project 4 – Initials 
 

Initials morph, follow a path and change transparency 
New Key Concept: Shape Tween 

 
 
1. Writing your initials and converting them into graphic objects 
 
Use File – New to create a new blank document.  
 
 

 Use the text tool to drag out a text box. Set the properties (from the 
properties panel at the bottom) to a large clear font and type two initials. 
For example: 

 
  

  
 
Now you are going to break apart the initials into 
separate art objects. Select both initials by dragging a 
box over them with the arrow tool. Go to Modify menu > 
Break Apart. This splits the initials into separate objects.  
Go to Modify menu > Break Apart again. Now they are 
converted into art objects. 
 

2. Organising layers, so that each initial is on a separate layer 
 
Add a layer and rename, so that you have one layer for each of your 
initials. 
 
You are going to do something different to each of the initials, so 
each one will have to be on a separate layer. (At the moment they 
are both on the bottom layer). Make sure you are on the bottom 
layer and use the arrow tool to select your second initial. Use Ctrl+X 
to cut the initial. Now click to select the  top layer and use 
Ctrl+Shift+V to ‘Paste in Place’. This pastes the object onto the new layer in 
exactly the same place as on the old layer. (This command is also accessible from 
the Edit menu). 

 
Check with the Show/Hide tool that you have each initial on the correct 
layer. 
 
 

 
3. Using Shape Tween to change the first initial 
 
The animation is going to last until frame 40, so drag the 
mouse down over both layers to highlight frame 40, then 
right click and Insert Keyframe.  
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Click on frame 1 of your first initial layer, select the initial and delete it. This is 
where we are going to draw the shape that will morph into the initial (which is 
still on frame 40). 
 
Use the Oval or rectangle tool, no stroke and any fill 
colour you like. Drag out a shape into the space left 
by the initial.  
 
Now you are going to add shape tween. (Remember 
that shape tween does not use symbols, unlike 
motion tween).  

 
Make sure to select the first frame and then go to the 
Properties panel.  Choose Shape from the Tween 
selections. You will notice that an arrow has appeared 
between that keyframe and the next. The frames also 
turn green, indicating shape tween.  

 
Play the shape tween by moving the playhead to frame 1 and pressing Enter. 
 
 
4. Improving the shape tween 
 
You can improve the morphing effect by adding ‘shape hints’. These tell Flash to 
map certain points in the first shape to points in the second shape.  
 

Click on the first frame again. Go to Modify 
menu > Shape > Add Shape Hint (or use 
Ctrl+Shift+H). A little yellow circle will appear, 
with the letter ‘a’. If you continue to add shape 
hints, they will be named b, c, d, etc. Place the 
hints round your shape. Then click on the final 
frame and move the green shape hints into 
corresponding positions. Play the movie again 
and adjust if necessary. 

Note: If you highlight all the frames between 1 and 40, you can remove the 
shape hints by going to Modify menu > Shape > Remove All Hints 
 
5. Adding a motion guide to move the second initial along a path 
 
For anything involving motion, you must have symbols. So select the second 
initial on the top layer and convert it to a graphic symbol as before. 
 
Now you are going to add a motion guide. Make sure 
you are on the correct layer. Click on the motion 
guide tool and you will see the Guide layer pop up 
above the initial layer. 
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You can draw the guide with any tool that makes a line. One of the easiest ways 
is to use the Oval or Rectangle tools. 

 
Click on the first frame of the Guide layer. 
Click on one of the shape tools, making sure the stroke is black and 
there is no fill. (The guide layer is invisible in the final animation). 
Draw out the path you want the initial to follow. 
 

Note: Holding down the shift key while drawing produces a perfect circle. If you 
are using the brush tool to draw the path, holding down shift will produce a 
straight line. Make sure that each new line joins on to the one before to make the 
path. If you want to move your path once you have drawn it, lock the other 
layers, drag a box round the path to select it and then drag into position. 
 
6. Positioning the initial along the guide line 
 
Insert keyframes at 10 frame intervals along the initial layer: 
 

 
 
Click on each of the keyframes in turn and position the initial by dragging it to 
snap to the motion guide path you drew. 
 
If you play the movie, you should see the initial jumping to different positions 
round the path. All you need to do now is create motion tween between all the 
keyframes in that layer. If the final ‘tween’ is a dashed line instead of an arrow, 
right click on the final keyframe and click Create Motion Tween again. 
 
7. Altering the transparency 
 
You can make this initial change its transparency as it moves along the path. 
Click on any of the keyframes, then click on the initial symbol itself to find the 
graphic symbol properties panel at the bottom of the window.  

 
Choose Alpha from the menu and adjust the percentage number or sliding scale. 
Note that you can alter other colour properties like tint and brightness instead. 
Now test the movie and save it. 
 
8. Extension 
 
Can you create a banner for a website where every letter of the site name does 
something different? Remember that file size is important for websites, so use 
symbols wherever possible. Note: FAQ1 (p18) explains how to change the shape 
of the stage before you start. 
Back to contents
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Project 5 – Button 
 

A button controls the starting of the movie 
New Key Concept: Button Symbol 

 
 
1. Adding a button symbol 
 
Note: This project uses the Initials file, so open this first. 
You are going to add a button which will play the movie again when clicked. First 
you must add a new layer at the top (drag it into the correct position if 
necessary) and call it ‘button’. The button is going to pop up at frame 40, so 
insert a keyframe at frame 40. 
 
Now create a button shape with the rectangle tool. You can give it 
rounded corners, if you wish and use the stroke size from the 
properties panel to alter the border. Drag out the rectangle and 
position it on the stage. 
Note: If a shape has a border (stroke), draw a box round the whole shape to 
select it before moving, or it will leave its border behind! 
 
Select the button 
shape and convert it 
to a symbol (Insert 
menu), this time 
choosing the Button 
symbol option.  
 
 
 
2. Assigning actions to the button 
 

Select the button, making sure that the thin blue 
frame is showing, then click on the Actions panel 
title bar for that symbol (above the properties 
panel). 

 
On the right of the Actions panel, check that you are in 
Normal Mode. 
 
You are going to set the actions so that on mouse 
release, the movie will go and play frame 1 again. 

 
  Click to open Actions, then Movie Control, then 
double click the word ‘on’: 

 
 
You do not need to change anything here. 



  www.sojomedia.com | info@sojomedia.com | +44 (0)1573 420 367 

 

  Waukford, Kirk Yetholm, Kelso, TD5 8PG 
 

14  

 
Now double click the word ‘goto’:  
Again there is nothing to change, as you 
can see from the actionscript. If you change 
to Expert Mode, you can see the code: 
 

  
 
Now the actions are set. 
 
3. Adding a stop action 
 
If you test the movie, you will see that it is still looping. You need to add a ‘stop’ 
action to stop the movie at frame 40. These can be added on any keyframe, but it 
is good practice to put them on a separate layer, so that they are easy to find and 
change. 
 

Add a new layer, name it ‘actions’ and insert a keyframe 
at frame 40. Go to the Actions panel, change back to 
Normal Mode and go to Actions > Movie Control. Double 
click on ‘stop’. 
 
Now test the movie. 
 
Finally add some text to the 
button to tell the user to click. (It 
is always better to add text after 
the button has been created).  
Note: You can add the text as a 

separate layer to the button symbol itself (double click the button first). 
 
 
4. Extension 
 
Can you add ‘stop’ and ‘go’ buttons to the movie and then use the Movie Control 
actions to make one button stop the movie when it is clicked and the other button 
start the movie again? 
Remember: Each button should be on a new layer 
 
Double clicking on a button symbol allows you to change how it looks when the 
mouse hovers over it. Can you alter the buttons so that they glow a different 
colour when the mouse moves over them? Or can you add a motion clip so that 
the button animates?  
Hint: Insert a keyframe in the ‘over’ state 
 
Explore the button library – go to Window menu > Common 
Libraries > Buttons. These buttons have actions already assigned, 
rather like the Action Buttons in PowerPoint. 
 
By setting the button alpha (transparency) properties to 0, you can make any 
area of your movie act as a button. Go back to the Face project – can you add a 
transparent button (and a stop action) so that the movie will not start until the 
face has been clicked? 
Back to contents
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Project 6 – Fish 
 

From one graphic symbol, a shoal of fish dart through the water 
New Key Concept: Instances 

 
 
1. Creating the fish graphic symbol 
 
You could draw your basic fish shape using the pencil tool. If 
so, make sure you choose the smooth option from the drop 
down selection.   
 

The alternative is to use the pen tool to draw a Bezier curve. 
Select the pen tool and click on the stage, moving the mouse slightly in 
the direction you want the curve to go. Then click where the curve will 
finish and drag the tangent handles until the curve looks right:  
    
 

 
 
 
When you let go, it will look like this: 
 
 
 
 
 
 
 

Select the curved line, copy it and paste, so you have 2 identical lines. Then use 
Modify menu > Transform > Flip Vertical to form the bottom half of the fish. 
 
A straight line for the tail and added eye detail completes the fish, which can be 
filled with a 3D effect fill: 

 
Note: If the fill tool is not 
working, it may be because there 
are gaps in the drawing. Use the 
Close Gaps options to fix this. 

  
Now, convert this to a graphic symbol as before (Insert 
menu) 
 
2. Using the graphic symbol ‘fish’ in a movie clip 
 
Open the Library from the Window menu and check that your graphic symbol is 
there, then delete the fish from the stage. It is now going to become an animated 
swimming fish! 
 
Go to Insert menu > New Symbol, as you did in Project 3, and create a movie clip 
symbol called ‘swim’. The timeline for the movie clip ‘swim’ opens up and you can 
drag the graphic symbol ‘fish’ onto the stage.  
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By inserting keyframes at 5 frame intervals and moving and rotating 
the fish, create an animation that makes the fish swim across the 
stage. Use the  Free Transform tool to rotate the fish (or Modify menu 
> Transform > Scale and Rotate). 
 
By altering the distance the fish moves each time (sometimes a short 
distance, sometimes long), a darting effect can be achieved. 
 
Add motion tween to make the swimming action smooth and play the movie clip, 
adjusting the keyframes if necessary.  
Using the ‘onion skin’ tool shows the path of my fish: 
 

 
  
Click on Scene 1 to leave the movie clip timeline and return to the main timeline. 
 
3. Creating the shoal of ‘swim’ movie clips 
 
First make a blue background for your fish. Go to Modify menu > Document and 
change the background colour. 
 
Name Layer 1 ‘swim’, because it is going to contain all your ‘swim’ movie clips. 
 
Drag the ‘swim’ movie clip from the Library onto the 
stage and test the movie by pressing Ctrl+Enter. 
 
Now you can add an ‘instance’ of the movie clip 
which can be altered without changing the original. 
Drag another ‘swim’ movie clip onto the stage. It 
may arrive with its registration point (around which it 
rotates) far away, so the first job is to move that 
point.   

Registration point 
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Click on the Free Transform tool and then drag the 
registration point to the centre of the fish. Now you 
can rotate the fish, so that it is setting off at a 
different angle from the first fish. You can also scale 
the instance to be larger or smaller. 

 
Finally, you can change the colour. Click on the instance 
and then alter the colour tint or brightness in the 
properties panel.   
 
Continue to add fish in the same way. Some can be 
swimming from the other direction. Move the registration point first, as before, 
and then flip the fish from the Modify menu > Transform. 

 
 Some fish can start from off 
the stage, so that they are 
moving on to the stage as 
others are leaving it. 
 
 
 
 
 
 

 
4. Extension 
 
The shoal is effective, but it is obvious that they all share the same 
movement pattern. Can you create a ‘swim2’ layer for all the instances 
of a new movie clip, with a different swimming pattern? 
Hint: You can duplicate the ‘swim’ movie clip and then alter that. Right 
click on ‘swim’ in the library and choose duplicate. Re-name ‘swim 
copy’ to ‘swim2’, then double-click to alter the movie clip. 
 
Some waterweed would add to the scene and can be easily drawn 
using the diagonal brush tool. Remember that you can use graphic 
symbols and instances to make the file smaller. 
 
Can you make the fish appear to swim in front of some of the weed and 
behind other parts of it? 
Hint: Use the position of your layers to achieve this. 
 
  
Back to contents
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Publishing the movie  
 
First the movie must be saved. 
 
Then click the arrow tool and go to the 
properties panel, clicking on the Flash Player 6 
button. 
 
You now have various options. Ticking each box makes a tab appear behind the 
Formats tab: 
 

 
 
If you tick Flash (.swf), a Flash file is published to where you saved the movie 
file. You can then embed this into a web page (in Dreamweaver, go to Insert > 
Media > Flash). 
 
If you tick HTML (.html), a web page containing your movie is published. 
 
If you tick GIF Image (.gif), an animated gif is published. 
 
In each case, clicking on the relevant tab allows you to change settings. Then just 
click on Publish. 
 
Now go to your file and check the file size. If you have used symbols correctly, 
your file size should be really small. Who managed to make the smallest movie? 
 
Back to contents
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 Frequently Asked Questions  
 
(also see the ‘Hints’ and ‘Notes’ through the course) 
 
Q. How can I change the shape of the stage? 
 
Think ahead! This is easy to do before you start making the movie, much harder 
once the movie is finished because your movie has been made to fit a particular 
shape. Simply click the arrow tool, go to the Properties panel and click ‘Size’. 
 
Q. Why won’t it let me draw on this layer? 
 
Three things to check: 
Have you got a keyframe inserted? 
Is the layer that you are trying to draw on being hidden by a layer above it? 
Does the colour of the brush/pencil match the background colour? 
 
Q. Why have my objects all turned into outlines? 
 
You have clicked on the Outline tool by mistake. This 
tool is used to help you line up layers. Just unclick it. 
 
Q. Why won’t it let me Convert to Symbol? 
 
Have you selected the object first? 
 
Q. Why are other things moving when I try to move one object? 
 
You have probably forgotten to put the new object on 
a separate layer – delete it and draw it again on its 
own layer. 
The other common problem is if, when converting to 
symbol, you managed to select parts of other layers 
by mistake. To solve it, drag the existing symbol in 
the Library to the bin and start again.  
 
To prevent it happening in the first place, lock other layers before selecting the 
object. 
 
Q. Why can’t I set the stroke tool to ‘No Stroke’? 
 
You only need this option if you are using the Oval or Rectangle tool, therefore 
click the tool first and then you will be given the option. 
 
Q. How can I add sound? 
 
Save your sound as a .wav file. Insert a new layer called ‘sound’ and insert a 
keyframe where the sound is to start. Then go 
to File menu > Import and navigate to the 
sound. Now click on the keyframe and go to the 
properties panel. Click on the drop-down menu 
to find your sound. 
 
You can now edit the sound ‘envelope’ with the Edit button in the properties 
panel. 



  www.sojomedia.com | info@sojomedia.com | +44 (0)1573 420 367 

 

  Waukford, Kirk Yetholm, Kelso, TD5 8PG 
 

20  

Q. How can I move all my frames along , so I can fit something in before 
the action starts? 
 
Just Select All Frames from the Edit menu and drag with the arrow tool. 
 
Q. Because I’ve moved all my frames, the button I set to go to frame 1 is 
not working properly! 
 
You can solve this by setting a frame label. Click on the 
keyframe where the action starts and give the frame a 
label on the Properties panel. A label appears in the 
timeline. 

When you set the actions in the Actions 

panel, you can set the goto command to 
go to a Frame Label instead of a Frame Number, by 
clicking the drop down Type options. 
 
Then you can select the correct label from the drop 
down Frame options. 
 
This means that the action will always go to the right 
frame even if that frame has moved. 
 
Q. How do I make new scenes? 
 
Insert menu > Scene. If you test the movie with Ctrl+Enter, it will play all the 
scenes. Ctrl+Alt+Enter tests the current scene. Note that you can set actions to 
go to different scenes, by selecting the Scene number from the Actions panel.  
 
Q. How can I find out more about how ActionScript works? 
 
A good start is to click the little book-shaped tool at the right of the 
Actions panel. This brings up a window that explains each action and 
gives examples. 
 
Q. How can I change the shape of a symbol (eg crashed car) without 
changing it throughout the movie? 
 
Pull an instance of the symbol onto the stage and then go to Modify > Break 
Apart. The object is no longer a symbol or an instance and you can do what you 
like with it. Then you can convert it to its own symbol if you wish. 
 
Q. How can I move my entire movie round the stage? 
 
First, make sure that none of the layers are locked (if you want to move only 
some layers, lock the other ones). 

 
Then click the Edit Multiple Frames tool and choose 
Onion All from the Modify Onion Markers tool. 
 
Go to Edit menu > Select All. You should now be able to 
move the entire animation.  
 
Back to contents 
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Online Flash MX Tutorials  
 
Online Flash MX tutorials are often dedicated to achieving very complicated 
irrelevant effects and are more off-putting than helpful.  
 
These tutorials are thoroughly recommended: 
 
 
Mark Weddell, Primary ICT Co-ordinator 
http://www.ks2.info/FlashInEducation/home.htm 
This would be a useful starter for S1 – a simple rocket launch with start and stop 
buttons. Very clear.  
 
 
 
The following 5 tutorials by John Lee are excellent: 
http://www.devx.com/webdev/Article/9724/0/page/1 
Learning to Draw in Macromedia Flash MX 

 
http://www.devx.com/webdev/Article/10251/0/page/1 
Learning to Animate in Macromedia Flash MX 
 
http://www.devx.com/webdev/Article/10639/0/page/1 
Slim Down Your Flash MX Animations with Graphic Symbols and Movie Clips 
 
http://www.devx.com/webdev/Article/11865/0 
Push Flash Interactivity with ActionScript Buttons 
 
http://www.devx.com/webdev/Article/15685/0 
Activate Your Flash Animations with ActionScript 
 
 
 
Two more sets of Flash introductory tutorials: 
http://www.echoecho.com/flash.htm 
 
http://www.w3schools.com/flash/default.asp 
 
 
Step-by-step pre-loader tutorial 
http://atl4.hostvelocity.com/~profal/cis127/flash/preloader-movie.htm 
Click the Contents button then Elevated, for some advanced ActionScript 
tutorials. 
 
 
 
Please let me know if you find good online Flash MX tutorials: 
jo@sojomedia.com 
 
 
 
 
Back to contents 


